Annonce

Faites la différence entre le service WordPress.com et l'application libre WordPress.

Mettez-vous à jour ! WordPress 4.0 est disponible en français.

Annonce 1 : Le Codex en français a besoin de vous pour avancer !
Annonce 2 : Avant de poster, n'oubliez pas de faire une petite recherche et de lire les règles de ce forum.
Annonce 3 : Lisez notre blog, il regorge de bonnes informations.
Annonce 4 : Rejoignez-nous sur Facebook, Google + et sur Twitter

#1 06-11-2005 17:36:44

z720
Modérateur fantome
Lieu: Thionville
Date d'inscription: 06-10-2005
Messages: 660
Site web

[Résolu] Problème avec fichier mo (reconnaissance du fichier)

Je suis devant un problème assez complexe à résoudre. Depuis que mon hébergeur a déplacé mon site sur un autre serveur, la traduction de WordPress ne fonctionne plus...

Actuellement,  mon hébergeur cherche de son côté pour voir quelles sont les différences entre les 2 serveurs.

Mais je me demandais si de votre côté vous aviez déjà eu ce genre de problème. Pour le moment j'ai réussi à isoler la cause du problème mais je n'arriv epas à le résoudre.

WordPress n'arrive pas à charger le fichier .mo parce que pour lui il n'est pas au bon format. (erreur 1 lors du chargement du fichier mo.)

Ce que j'ai déjà essayé :
- mettre à jour WordPress
- charger un nouveau fichier mo en encodage UTF et Latin1.

Si vous avez des idées...

Hors ligne

 

#2 24-11-2005 14:40:17

z720
Modérateur fantome
Lieu: Thionville
Date d'inscription: 06-10-2005
Messages: 660
Site web

Re: [Résolu] Problème avec fichier mo (reconnaissance du fichier)

Mon hébergeur m'a donné une solution que ne me convient qu'à moitié, puisqu'il faut modifier du code WordPress :
Dans le fichier wp-include/gettext.php (vers les lignes 105)
Remplacer

Code: html

    // $MAGIC1 = (int)0x950412de; //bug in PHP 5
    $MAGIC1 = (int) - 1794895138;
    // $MAGIC2 = (int)0xde120495; //bug
    $MAGIC2 = (int) - 569244523;

Par

Code: html

    $MAGIC1 = (int)0x950412de; //bug in PHP 5
    //$MAGIC1 = (int) - 1794895138;
     $MAGIC2 = (int)0xde120495; //bug
    //$MAGIC2 = (int) - 569244523;

Chez moi ça remarche mais je ne suis pas très convaincu. Donc si vous avez le même problème un jour, c'est une piste à explorer...

Cette info s'applique à WordPress 1.5.2, voir si le problème est le même avec la version 2.0

Hors ligne

 

#3 24-11-2005 14:50:14

Damino
Modo Furtif !
Lieu: Paris
Date d'inscription: 19-09-2005
Messages: 1633
Site web

Re: [Résolu] Problème avec fichier mo (reconnaissance du fichier)

Et c'est qui ton hébergeur cela pourrait nous interresser.

On attend le secours du spécialiste ... Xavier !

Hors ligne

 

#4 24-11-2005 16:11:39

Xavier
Photogénique en noir et blanc
Lieu: Paris
Date d'inscription: 19-09-2005
Messages: 2418
Site web

Re: [Résolu] Problème avec fichier mo (reconnaissance du fichier)

Mmmh, je ne peux dire grand de l'implémentation PHP de la traduction. Seb, le code présenté est celui de WP ? Les lignes en commentaire y sont ? Donc jusqu'à que que les Dev fassent leur boulot correctement (WP 2.0 ?), je crois que tu vas devoir faire valser les commentaires, effectivement... Pas pratique.


Mainteneur de la traduction de WordPress
http://xavier.borderie.net/wp-fr/

Hors ligne

 

#5 25-11-2005 10:43:26

z720
Modérateur fantome
Lieu: Thionville
Date d'inscription: 06-10-2005
Messages: 660
Site web

Re: [Résolu] Problème avec fichier mo (reconnaissance du fichier)

Mon hébergeur est planet-work.

Pour ajouter à la bizarrerie : tout fonctionne correctement sur mon installation locale : WinXP / Apache 2 / PHP 4.xxx

Hors ligne

 

#6 29-03-2006 12:48:54

studio224
Membre WP
Date d'inscription: 29-03-2006
Messages: 1

Re: [Résolu] Problème avec fichier mo (reconnaissance du fichier)

smile Bonjour,

le problème s'est posé pour moi avec la version 2.02, pourtant mon hébergeur n''utilise pas PHP 5 mais la Version 4.4.2. (Or si j'ai bien compris la rectif... c'est pour un bug quand on utilise PHP5 ?)

J'ai appliqué la solution ci-dessus et ça a marché au poil. J'ajoute que mon problème c'était la version portugaise de WP et je suis tombée sur le forum français en désespoir de cause car je ne trouvais pas de solution sur le forum officiel en anglais. Je dirais qu'il y a bien un bug quelque part...

Anne-Claire

Dernière modification par studio224 (29-03-2006 12:49:34)

Hors ligne

 

Pied de page des forums

Propulsé par PunBB 1.2.23
© Copyright 2005-2006 WordPress France

[ Generated in 0.040 seconds, 13 queries executed ]